memorandums

日々のメモです。

devkitpro

VistaNDS開発環境であるdevkitproをインストールしたところ、ビルドでエラーが出ました。パスがうまく通っていないのかと調べたところ、devkitpro-arm-users のメーリングリストアーカイブに以下の書き込み(4/2)がありました。

The current devkitARM ( release 20 ) is not compatible with Vista.
Personally I think that's actually the other way round but MicroSoft are
a lot bigger than I am so that approach won't get me far ;o)
I have a fix in progress which will be incorporated in release 21.
Dave

詳しくはわかりませんが、VistaではセキュリティのためWindowsAPIが変更されているようです。XPで動作していたWindows版のオープンソースの多くはそのまま動作させるのは難しいのかも知れません。ただxamppは動作しましたのでビルドが必要な場合に限るかも知れません。

いずれにせよdevkitproはしばらくVistaでは使えないようです。待ちますか。