memorandums

日々の作業ログです。

netbeans6.8 + windowsxp(vmware fusion) + fastdebugger(ruby-debug-ide)のインストールできない

これも知っている人からするとしょうもないことなのでしょうけど。。。ハマったので解決方法を書いておきます>自己メモのために。タイトルの通りです。解決方法はこちらこちらを参考にしました。

以下のファイルをローカルにDLします(展開ツールのせいだと思うのですがwinでやるとフォルダになってしまいました。時間がないのでmacでDLしてwinにコピーしました)。

http://rubyforge.org/frs/download.php/46863/ruby-debug-base-0.10.3-mswin32.gem

その後、上記ファイルがあるディレクトリに移動してコマンドプロンプトruby console)で以下を入力します。

gem install ruby-debug-base -l

恐らく成功するはずなので続いて以下を入力します。

gem install ruby-debug

最後に以下を入力します。(よくわかりませんが古いバージョンじゃないと入らないようです)

gem install ruby-debug-ide -v "0.4.4"

これでnetbeansに戻るとデバッガーが使えるようになりました。