memorandums

日々のメモです。

mac(SnowLeopard)+netbeans6.8+ruby1.8.7でデバッガが動作しない

実は先日、解決済みだったのですが、なぜ解決できたかわからなかったのでメモしませんでした。。。もう1台のmacで同じ現象が。。。とりあえず試してみたのは以下の通りです。

ruby-debug関係の状況調査

gem list ruby-debug

LOCAL GEMS ***

ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.5)


ruby-debug-ideを更新

sudo gem install ruby-debug-ide
gem list ruby-debug

LOCAL GEMS ***

ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.9, 0.4.5)

→結果、変わらず。


ruby-debugをインスト(関係ないと思うけど)

sudo gem install ruby-debug
gem list ruby-debug

LOCAL GEMS ***

ruby-debug (0.10.3)
ruby-debug-base (0.10.3)
ruby-debug-ide (0.4.9, 0.4.5)

→結果、変わらず。


■そういえば、何かアップデートした覚えが。。。ぐぐって思い出したlinecacheだ。調べてみよう。

gem list linecache

LOCAL GEMS ***

linecache (0.43)

→入っているな。。。とりあえずもう一度インストーるしてみよう。


■linecacheをインストール

gem install linecache

→結果、netbeansでデバッガが起動するようになりました。よくわかりませんが、恐らく、再インストールによって関連が更新されたのではないかと思います。とりあえずデバッグができればいいのでここで終了。