読者です 読者をやめる 読者になる 読者になる

memorandums

日々のメモです。

AnyLogic起動でエラーがでる

mac anylogic 研究

研究で購入したAnyLogic(University版)。なかなか手をつけることができずにいます。

ひさしぶりに起動すると6.8から6.9にバージョンアップしていました。

6.8のライセンスでも6.9に適用されるようです。

上書きインストールしてmacbook proで起動すると以下のエラー。。。あれ?

f:id:ke_takahashi:20130515172409p:plain

Javaのエラーっぽい。

いろいろと調べると、以前、7が出たときに遊んだOpenJDKが邪魔をしているようでした。

JREJDKを入れ直し。。。てもダメ。

結局は上記のエラーメッセージに書いてある通りでした。

/Libraryではなく~/Library以下のopenjdkをインストールしたらしくそれが悪さをしていたようです。

~/Library/Java/JavaVirtualMachines/の下を削除して、Oracleより最新のJDKを入れ直したところ起動できました。